Changes between Initial Version and Version 1 of MyEditorGuide

Show
Ignore:
Timestamp:
7/28/2009 3:33:16 PM (10 years ago)
Author:
anonymous (IP: 10.86.5.34)
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • MyEditorGuide

    v1 v1  
     1=== I am getting svn import errors with trac, what's going on? === #i-am-getting-svn-import-errors-with-trac-what-s-going-on 
     2Make sure you install the Python bindings of Subversion, just having Subversion is not good enough. 
     3 
     4The error reported by Trac will look something like this: 
     5 
     6{{{ 
     7  Indexing repository 
     8  Failed to initialize environment. No module named svn 
     9  Traceback (most recent call last): 
     10  File "/usr/lib/python2.3/site-packages/trac/scripts/admin.py", line 616, in do_initenv repos = self.__env.get_repository() 
     11  File "/usr/lib/python2.3/site-packages/trac/env.py", line 155, in get_repository from trac.versioncontrol.svn_fs import SubversionRepository 
     12  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/svn_fs.py", line 25, in ?  from svn import fs, repos, core, delta 
     13  ImportError: No module named svn 
     14 
     15}}} 
     16''Note that in recent versions of Trac, this error reads rather: `TracError: Unsupported version control system "svn".` ''. 
     17 
     18To verify you should have a `libsvn` and `svn` directory underneath Python's `site-packages` directory, but see rather [http://trac.edgewall.org/wiki/TracSubversion#unsupported-vcs TracSubversion#unsupported-vcs] for more detailed troubleshooting information. 
     19 
     20  If you do not have this use something like the following to fix this: 
     21 
     22On Gentoo Linux: 
     23 
     24{{{ 
     25  USE="python" emerge subversion 
     26 
     27}}} 
     28On FreeBSD use the `ports/devel/subversion-python` port (preferred way) or `ports/devel/subversion` with 
     29 
     30{{{ 
     31  WITH_PYTHON=true 
     32 
     33}}} 
     34When using pkgsrc, please make sure to use the `pkgsrc/devel/py-subversion` pkg.